RFR: 8276299: G1: Unify the wording buffer/node/element in G1SegmentedArrayXxx, G1CardSetXxx and related classes

Hamlin Li mli at openjdk.java.net
Tue Nov 30 02:17:23 UTC 2021

Currently, the words "buffer", "node" and "element" are used together in G1SegmentedArrayXxx, G1CardSetXxx and related classes in an inconsistent way, which is very unfavorable for understanding.

We should not confuse buffer and node together, and not confuse node and element together. The new wording should be based on something like the following rule:

segmented array (1) -- segment (N) -- slot (M)


Commit messages:
 - Initial commit

Changes: https://git.openjdk.java.net/jdk/pull/6605/files
 Webrev: https://webrevs.openjdk.java.net/?repo=jdk&pr=6605&range=00
  Issue: https://bugs.openjdk.java.net/browse/JDK-8276299
  Stats: 367 lines in 14 files changed: 2 ins; 0 del; 365 mod
  Patch: https://git.openjdk.java.net/jdk/pull/6605.diff
  Fetch: git fetch https://git.openjdk.java.net/jdk pull/6605/head:pull/6605

PR: https://git.openjdk.java.net/jdk/pull/6605

More information about the hotspot-gc-dev mailing list