RFR JDK-8039525: HashTable lookup API needs refactoring

Christian Thalinger christian.thalinger at oracle.com
Fri Apr 25 01:21:27 UTC 2014

I don’t think we need the suffix _only if we have _and_add.  The lookups are then doing what they are supposed to do.

On Apr 24, 2014, at 10:59 AM, Gerard Ziemski <gerard.ziemski at oracle.com> wrote:

> hi all,
> Please review this simple enhancement, which renames symbolTable::lookup API using names that better reflect the method purpose, ie: lookup_only, lookup_and_add, lookup_only_and_hash, lookup_and_add_unicode and lookup_only_and_hash_unicode.
> No new or removed code.
> Webrev: http://cr.openjdk.java.net/~gziemski/8039525_rev0
> Bug: https://bugs.openjdk.java.net/browse/JDK-8039525
> Tested with hotspot jtreg, vm.quicklooks and JPRT. Locally builds on Mac OS X and Linux.
> Thank you.

More information about the hotspot-runtime-dev mailing list