RFR (round 2) JDK-8039525: HashTable lookup API needs refactoring
john.r.rose at oracle.com
Fri May 9 19:55:49 UTC 2014
On May 9, 2014, at 12:48 PM, Coleen Phillimore <coleen.phillimore at oracle.com> wrote:
> This looks okay to me also. The renaming of "probe" to "lookup_and_ignore_hash" seems odd to me since nowhere in the caller do you suspect there's a hash code of any interest. I would have picked simply "lookup" since the old "lookup" turned into "lookup_and_add". If this makes it clearer to you while working on this code, then it is fine.
I would also be happy to see "_ignore_hash" go away, for the reason you give. Generally speaking if an API point has an optional argument, we may give a longer name to the method that takes the optional argument, not to the method that omits or ignores it.
More information about the hotspot-runtime-dev