RFR 8068730: Increase the precision of the implementation of java.time.Clock.systemUTC()
daniel.fuchs at oracle.com
Mon Jan 12 17:17:24 UTC 2015
On 12/01/15 15:41, Daniel Fuchs wrote:
> On 12/01/15 13:49, Stephen Colebourne wrote:
>> On 12 January 2015 at 12:00, Daniel Fuchs <daniel.fuchs at oracle.com>
>>> I'm not a big fan of the current name either.
>>> I would gladly rename it. I did think of
>>> windows_to_java_time_micros, but it actually returns tenth of
>>> micros - so it would be lying...
>>> Is there a good name for 'tenth of micros'?
>> .NET refers to them as "ticks".
> Ah! That's a good one. 'windows_to_time_ticks' I like this better :-)
Here is the new webrev. Testing on windows went well :-)
> Thanks Stephen!
> -- daniel
More information about the hotspot-runtime-dev