Request Review: JDK-6479237 (cl) Add support for classloader names

Mandy Chung mandy.chung at
Thu Nov 3 16:29:10 UTC 2016

> On Nov 3, 2016, at 8:52 AM, Coleen Phillimore <coleen.phillimore at> wrote:
> My problem with fillStackTraceFromThrowable, besides it being a really long name, is that it's too close to fillInStackTrace which is a known API and should not be changed.
> Why not keep JVM_ToStackTraceElement, and change JVM_GetStackTraceElements if you really need to to JVM_ToStackTraceElementArray().
> Or even JVM_ToStackTraceElements() which is very close to the function that it should conceptually be an overloaded instance.
> Throwable is part of the API, so putting it in the name is redundant and too long.  Sorry for caring maybe overly about the names. That's how I find things.

These two methods are part of StackTraceElement APIs not Throwable, in case it’s not clear to you.

What about SetStackTraceElement* or another alternative InitStackTraceElement*

JVM_SetStackTraceElementArray(JNIEnv *env, jobjectArray elements, jobject throwable);

JVM_SetStackTraceElement(JNIEnv* env, jobject element, jobject stackFrameInfo);

BTW - do you know any known issue as JPRT hotspot test jobs are failing on jdk9/hs and jdk9/dev?


More information about the hotspot-runtime-dev mailing list