RFR: 8176472: Lazily create ModuleEntryTable

harold seigel harold.seigel at oracle.com
Fri Apr 14 15:03:14 UTC 2017

Hi Rachel,

The changes look good!  They will definitely save memory.

Would it be useful to rename ModuleEntry::has_reads() to something like 
ModuleEntry::has_reads_list() ?

Thanks, Harold

On 4/14/2017 10:34 AM, Rachel Protacio wrote:
> Hello!
> Please review this enhancement which moves the unnamed module out of 
> the ModuleEntryTable and into the ClassLoaderData so that the MET can 
> be lazily created only when other modules are present. The 
> PackageTable size has also been updated to be more realistic. These 
> two changes save the VM from losing memory space unnecessarily in the 
> module data structures.
> Tested with JPRT and RBT tiers 2-5.
> Bug: https://bugs.openjdk.java.net/browse/JDK-8176472
> Open webrev: http://cr.openjdk.java.net/~rprotacio/8176472.00/
> Thank you,
> Rachel

More information about the hotspot-runtime-dev mailing list