RFR(XXS/M): 8193135 - get rid of redundant _smr_ prefix/infix in ThreadSMRSupport stuff
Daniel D. Daugherty
daniel.daugherty at oracle.com
Fri Dec 8 20:19:45 UTC 2017
Thanks for the review!
On 12/8/17 2:51 PM, coleen.phillimore at oracle.com wrote:
> Hi Dan,
> These changes look good. The shortened names look much more
> meaningful and easier to read with the class name ThreadsSMRSupport
> On 12/8/17 10:25 AM, Daniel D. Daugherty wrote:
>> This should be last of the big Thread-SMR cleanup reviews! Stefan K,
>> is one of your Thread-SMR follow-up suggestions so I need to hear
>> from you
>> on this thread. Thanks!
>> In terms of actual "new/changed" code, this is an "XXS" review. However,
>> because of renaming, the changed/insert/delete counts are the size of an
>> "M" review. This is another simple (but tedious) review; I found that
>> the "udiffs" were easier than "frames" to verify the fix.
>> Here is the bug:
>> JDK-8193135 get rid of redundant _smr_ prefix/infix in
>> ThreadSMRSupport stuff
>> Here is the full webrev:
>> Because of the removal of the '_smr_' prefix/infix, some functions had
>> to be moved to stay in proper sort order. I've created separate delta
>> webrevs to separate the renaming from the code motion.
>> Here is the renaming part of the review:
>> Here is the code motion part of the review:
>> This fix is being (over) tested with a Mach5 tier[1-5] run.
>> The code motion part was sanity checked by extracting the pre-move code
>> into a file, extracting the post-move code into another file and
>> the two files. I didn't come up with a good way to automate the sanity
>> checking of the removal of the '_smr_' prefix/infix; that was
>> by the fact that the two 'smr_delete()' functions were not renamed to
>> Thanks, in advance, for any comments, questions or suggestions.
More information about the hotspot-runtime-dev