RFR (XS) 8205702: assert(UseCompressedClassPointers) failed in universe.hpp

Jiangli Zhou jiangli.zhou at oracle.com
Wed Jun 27 16:16:15 UTC 2018

Hi Per,

Here is the tmpfs I ran into. Setting -XX:ZPath=/run/shm seems to work.

[0.013s][error][gc,init] More than one tmpfs filesystem found:
[0.013s][error][gc,init]   /run/lock
[0.013s][error][gc,init]   /run/shm
[0.013s][error][gc,init] Use -XX:ZPath to specify the path to a tmpfs filesystem
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.


> On Jun 27, 2018, at 12:33 AM, Per Liden <per.liden at oracle.com> wrote:
> On 06/26/2018 11:57 PM, Jiangli Zhou wrote:
>> Hi Coleen,
>> This looks good.
>> Should we also disable UseSharedSpaces at runtime for ZGC in case an archive was dumped using a different GC algorithm? I ran into tmpfs error when trying to run with ZGC, so I couldn’t double check for that case...
> What kind of tmpfs errors? I would like to know if we have a bug somewhere or if it's user error.
> /Per
>> Thanks,
>> Jiangli
>>> On Jun 26, 2018, at 2:13 PM, coleen.phillimore at oracle.com wrote:
>>> Summary: Disable CDS with ZGC
>>> Tested with:
>>> java -XX:+UnlockExperimentalVMOptions -XX:+UseZGC -Xshare:dump
>>> java -XX:+UnlockExperimentalOptions -XX:+UseZGC -Xshare:on -version
>>> open webrev at http://cr.openjdk.java.net/~coleenp/8205702.01/webrev
>>> bug link https://bugs.openjdk.java.net/browse/JDK-8205702
>>> Thanks,
>>> Coleen

More information about the hotspot-runtime-dev mailing list