RFR: 8199717: Avoid calculating primordial thread stack bounds on VM startup
thomas.stuefe at gmail.com
Tue Mar 27 12:37:15 UTC 2018
On Tue, Mar 27, 2018 at 2:31 PM, Claes Redestad <claes.redestad at oracle.com>
> Hi Thomas,
> On 2018-03-27 14:17, Thomas Stüfe wrote:
>> Hi Claes,
>> change looks ok, although I would prefer a different, clearer name for
>> this variable. How about "suppress_primordial_thread_recognition" ?
> not sure I find that any clearer... how about "primordial_thread_detached"?
Hmm.. I find that actually worse than "might_be_primordial_thread".
Okay, I am fine with the original name.
I often use an int in these cases to have a trinary value, with -1 being
the default value meaning "uninitialized", so that I can assert that
initialization ran before using the value the first time. But I leave it up
to you if you want this.
If you add at least initialization to "true" like Robin proposed the change
is fine to me. No need for a new webrev.
More information about the hotspot-runtime-dev