RFR: 8230043: Lazily load libverify

Claes Redestad claes.redestad at oracle.com
Mon Oct 7 14:02:03 UTC 2019

On 2019-10-07 15:28, Alan Bateman wrote:
> What you have is okay, I was mostly interesting in seeing if we could 
> rename verifyFixClassname to fixClassname that returns JNI_TRUE if it 
> succeeds and JNI_FALSE if fails due to a slash. We can look at that 
> another time, I don't want to delay this improvement.

Thanks, Alan.

For the future, I'd also like to think about whether we can consolidate
all this . -> / translation stuff into a shared utility rather than
having code in libjava and HotSpot doing the same thing.


More information about the hotspot-runtime-dev mailing list