RFR (S) 8243503: InstanceKlass::_array_name is not needed and leaks

coleen.phillimore at oracle.com coleen.phillimore at oracle.com
Fri Apr 24 18:22:59 UTC 2020

On 4/24/20 1:32 PM, Lois Foltan wrote:
> On 4/23/2020 7:07 PM, coleen.phillimore at oracle.com wrote:
>> Summary: decrement the refcount for all Klass in class unloading.
>> See bug for more details.  Tested with tier1-6.
>> open webrev at 
>> http://cr.openjdk.java.net/~coleenp/2020/8243503.01/webrev
>> bug link https://bugs.openjdk.java.net/browse/JDK-8243503
>> Thanks,
>> Coleen
> Hi Coleen,
> Looks good.  Minor nit, can you keep part of the comment in 
> instanceKlass.cpp line #590, "which includes reference counting symbol 
> names"?  I find that helpful.

Hi Lois,

I restored the comment.  It made me notice that I had a bug.  The 
Klass::release_C_heap_structures should be called by 
InstanceKlass::release_C_heap_structures_internal() so that the _name 
refcount is decremented for redefinition too.  I retested with the 
redefinition tests (which exercise this code) and runThese which does a 
lot of class unloading and will sanity check this with tier1.

open webrev at http://cr.openjdk.java.net/~coleenp/2020/8243503.02/webrev
bug link https://bugs.openjdk.java.net/browse/JDK-8243503

> Thanks,
> Lois

More information about the hotspot-runtime-dev mailing list