RFR: 8246837: Rename WeakHandle<vm_class_loader_data> to better reflect its OopStorage association

coleen.phillimore at oracle.com coleen.phillimore at oracle.com
Tue Jun 9 11:34:51 UTC 2020

This looks great.  Thanks for fixing the name.  This is trivial and 
doesn't need another review.

On 6/9/20 4:11 AM, Erik Österlund wrote:
> Hi,
> WeakHandle<vm_class_loader_data> uses the OopStorageSet::vm_weak() 
> OopStorage. This is not obvious from the name. In particular, it 
> becomes problematic when new weak handles are created in other areas 
> of the VM, using the same OopStorage. I don't want them to go under 
> the vm_class_loader_data name, when they have nothing to do with that. 
> It seems more intuitive to name them vm_weak_data, reflecting which 
> OopStorage they are associated with.
> Bug:
> https://bugs.openjdk.java.net/browse/JDK-8246837
> Webrev:
> http://cr.openjdk.java.net/~eosterlund/8246837/webrev.00/
> Thanks,
> /Erik

More information about the hotspot-runtime-dev mailing list