RFR: 8271128: InlineIntrinsics support for 32-bit ARM

Christoph Göttschkes cgo at openjdk.java.net
Thu Aug 5 12:30:56 UTC 2021

On Thu, 5 Aug 2021 09:36:48 GMT, Aleksey Shipilev <shade at openjdk.org> wrote:

> Sorry for not catching this earlier, but I think `java_lang_math_abs` and `java_lang_math_sqrt` are not transcendental, so it is awkward to call `generate_transcendental_entry` for them? I think that's just a naming problem, maybe call it `generate_math_runtime_entry`? (If you fix this, maybe also pull from master to get clean GHA runs).

I chose that name because of the aarch64 implementation, which uses the same name (but doesn't generate calls for neither `abs`, nor `sqrt`). I renamed it to `generate_math_runtime_call`, since it only generates the call to the runtime function.


PR: https://git.openjdk.java.net/jdk/pull/4927

More information about the hotspot-runtime-dev mailing list