RFR: 8271128: InlineIntrinsics support for 32-bit ARM
shade at openjdk.java.net
Thu Aug 5 15:55:27 UTC 2021
On Thu, 5 Aug 2021 12:27:20 GMT, Christoph Göttschkes <cgo at openjdk.org> wrote:
> > Sorry for not catching this earlier, but I think `java_lang_math_abs` and `java_lang_math_sqrt` are not transcendental, so it is awkward to call `generate_transcendental_entry` for them? I think that's just a naming problem, maybe call it `generate_math_runtime_entry`? (If you fix this, maybe also pull from master to get clean GHA runs).
> I chose that name because of the aarch64 implementation, which uses the same name (but doesn't generate calls for neither `abs`, nor `sqrt`). I renamed it to `generate_math_runtime_call`, since it only generates the call to the runtime function.
Thanks, that looks better. `transcendental_entry` local variable too?
More information about the hotspot-runtime-dev