<i18n dev> RFR: 8257964: Broken Calendar#getMinimalDaysInFirstWeek with java.locale.providers=HOST [v2]
joehw at openjdk.java.net
Fri Dec 11 01:51:59 UTC 2020
On Fri, 11 Dec 2020 01:25:48 GMT, Naoto Sato <naoto at openjdk.org> wrote:
>> src/java.base/windows/classes/sun/util/locale/provider/HostLocaleProviderAdapterImpl.java line 78:
>>> 76: // CalendarData value types
>>> 77: private static final int CD_FIRSTDAYOFWEEK = 0;
>>> 78: private static final int CD_MINIMALDAYSINFIRSTWEEK = 1;
>> Do we want to keep the naming consistent, doing the same change to, e.g. the corresponding macosx impl?
> The constants are for native methods, which differ between macOS and Windows. Thus I thought it would be clearer to align the name with Windows' constants.
More information about the i18n-dev