<i18n dev> RFR: 8253497: Core Libs Terminology Refresh
bchristi at openjdk.java.net
Tue Dec 15 01:38:59 UTC 2020
On Mon, 14 Dec 2020 21:08:35 GMT, Joe Wang <joehw at openjdk.org> wrote:
>> This is part of an effort in the JDK to replace archaic/non-inclusive words with more neutral terms (see JDK-8253315 for details).
>> Here are the changes covering core libraries code and tests. Terms were changed as follows:
>> 1. grandfathered -> legacy
>> 2. blacklist -> filter or reject
>> 3. whitelist -> allow or accept
>> 4. master -> coordinator
>> 5. slave -> worker
>> Addressing similar issues in upstream 3rd party code is out of scope of this PR. Such changes will be picked up from their upstream sources.
> src/java.management.rmi/share/classes/javax/management/remote/rmi/RMIConnectorServer.java line 152:
>> 150: * <p>
>> 151: * Care must be taken when defining such a filter, as defining
>> 152: * an accept-list too restrictive or a too-wide reject-list may
> would "an allow-list too restrictive or a reject-list too wide" read better?
I agree that there is room for improvement here. How about:
"...an allow-list too restrictively, or a reject-list too broadly, may..."
More information about the i18n-dev