[11u] RFR 8209186: Rename SimpleThresholdPolicy to TieredThresholdPolicy

Aleksey Shipilev shade at redhat.com
Wed Jun 26 10:34:09 UTC 2019

Original RFE:

Patch does not apply to 11u cleanly, because JDK-8222670 backport went in first. This actually
highlights the benefit for making the rename early, to fit any future backports (notably JDK-8076988
and JDK-8216375).

So, I had to recreate the patch by hand. As in original patch, we move .inline.hpp into .cpp, along
with includes. Then we rename SimpleThresholdPolicy -> TieredThresholdPolicy.

11u webrev:

Testing: tier1


More information about the jdk-updates-dev mailing list