Review Request: 8173381: osName/osArch/osVersion is missing in ModuleDescriptor created by SystemModules
Alan.Bateman at oracle.com
Sat Jan 28 18:01:00 UTC 2017
On 27/01/2017 06:21, Mandy Chung wrote:
> Updated webrev:
This mostly looks good.
I think it would cleaner if the plugin used rewriter.targetPlatform("",
"", "") rather than adding filtering to the extender.
For the secret option for testing then I assume it should be
"retainModuleTarget" rather than "retainTargetPlatform". There are a
couple of places that use the old name in method names and maybe we
should rename those too. One other rename is the plugin has
"PackagesAttribute" when it should be "ModulePackages" attribute.
More information about the jigsaw-dev