Review Request: 8173381: osName/osArch/osVersion is missing in ModuleDescriptor created by SystemModules

Alan Bateman Alan.Bateman at
Sun Jan 29 21:56:42 UTC 2017

On 28/01/2017 20:50, Mandy Chung wrote:

> :
> I agree that would be cleaner and made the change. That’s what I started with but that’d leave ModuleTarget attribute in the class file.
>> For the secret option for testing then I assume it should be "retainModuleTarget" rather than "retainTargetPlatform". There are a couple of places that use the old name in method names and maybe we should rename those too. One other rename is the plugin has "PackagesAttribute" when it should be "ModulePackages" attribute.
> I fixed up a few places in ModuleInfoExtender as well.
The updated webrev looks okay and I think okay to keep the ModuleTarget 
attribute with empty values.

A minor comment on is that 
Object.class.getModule().getDescriptor() would be a simpler way to get 
the descriptor for the base module.


More information about the jigsaw-dev mailing list