<div dir="ltr">Hello all,<div>I am currently trying to test graal using shenandoah gc.</div><div>i follow the instructions bellow:<br></div><div>on the jdk :</div><div><pre style="color:rgb(0,0,0);white-space:pre-wrap">bash configure --with-boot-jdk=/opt/jvms/jdk-14.0.2 --with-jtreg=/opt/jtreg</pre><pre style="color:rgb(0,0,0);white-space:pre-wrap">make graal-builder-image</pre><pre style="color:rgb(0,0,0);white-space:pre-wrap"><pre style="white-space:pre-wrap">make run-test TEST="hotspot/jtreg/gc/shenandoah"</pre><pre style="white-space:pre-wrap">export JAVA_HOME=path/to/jdk/build/linux-x86_64-server-release/images/graal-builder-jdk</pre><pre style="white-space:pre-wrap">/opt/jtreg/bin/jtreg -v -vmoptions:"-XX:+UseShenandoahGC -XX:ShenandoahGCMode=passive -XX:+UnlockDiagnosticVMOptions -XX:+UseJVMCICompiler" ~/jdk/test/hotspot/jtreg/gc/shenandoah</pre><pre style="white-space:pre-wrap">and the output is:Test results: no tests selected</pre><pre style="white-space:pre-wrap">When i change the tests path from </pre><pre style="white-space:pre-wrap">~/jdk/test/hotspot/jtreg/gc/shenandoah<br></pre><pre style="white-space:pre-wrap">to:</pre><pre style="white-space:pre-wrap">~/jdk/test/hotspot/jtreg/gc<br></pre><pre style="white-space:pre-wrap">it starts running all the tests located there and my professor who used the same instructions had it working fine.</pre><pre style="white-space:pre-wrap"><span style="color:rgb(88,96,105);font-family:SFMono-Regular,Consolas,"Liberation Mono",Menlo,monospace;font-size:12px;text-align:right;white-space:nowrap">jdk commit </span><span class="gmail-sha gmail-user-select-contain" style="box-sizing:border-box;font-family:SFMono-Regular,Consolas,"Liberation Mono",Menlo,monospace;font-size:12px;color:rgb(68,77,86);text-align:right;white-space:nowrap">e2196f8882b9237926c3ff208bc971c5c31faac7</span><br></pre>openjdk 16-internal 2021-03-16<br>OpenJDK Runtime Environment (build 16-internal+0-adhoc.bakdim.jdk)<br><pre style="white-space:pre-wrap"><span style="font-family:Arial,Helvetica,sans-serif">OpenJDK 64-Bit Server VM (build 16-internal+0-adhoc.bakdim.jdk, mixed mode, sharing)</span> </pre><pre style="white-space:pre-wrap"><br></pre><pre style="white-space:pre-wrap">jtreg, version 5.1 dev 885<br>Installed in /opt/jtreg/lib/jtreg.jar<br>Running on platform version 16-internal from /home/bakdim/Documents/thesis/jdk/build/linux-x86_64-server-release/images/graal-builder-jdk.<br>Built with Java(TM) 2 SDK, Version 1.8.0_172-b11 on September 21, 2020.<br>Copyright (c) 1999, 2019, Oracle and/or its affiliates. All rights reserved.<br>Use is subject to license terms.<br>JT Harness, version 6.0 ea b11 (September 21, 2020)<br>JCov 3.0-2<br>TestNG (testng.jar): version unknown<br>TestNG (jcommander.jar): version 1.72<br>Java Assembler Tools, version 7.0 beta b02 (September 21, 2020)<br></pre><pre style="white-space:pre-wrap">does anyone have any clue on why this happens?</pre><pre style="white-space:pre-wrap">Thank you in advance.</pre></pre></div></div>