Vladimir.Zakharov at gs.com
Mon Feb 18 20:06:12 PST 2013
Sounds reasonable. "forEachWithCancel", perhaps "forEachUntilCancelled" (either works as it implies an external actor doing the cancellation).
The Goldman Sachs Group, Inc. All rights reserved.
See http://www.gs.com/disclaimer/global_email for important risk disclosures, conflicts of interest and other terms and conditions relating to this e-mail and your reliance on information contained in it. This message may contain confidential or privileged information. If you are not the intended recipient, please advise us immediately and delete this message. See http://www.gs.com/disclaimer/email for further information on confidentiality and the risks of non-secure electronic communication. If you cannot access these links, please notify us by reply message and we will send the contents to you.
From: lambda-libs-spec-experts-bounces at openjdk.java.net [mailto:lambda-libs-spec-experts-bounces at openjdk.java.net] On Behalf Of Brian Goetz
Sent: Monday, February 18, 2013 3:51 PM
To: lambda-libs-spec-experts at openjdk.java.net
Based on further user feedback, I think the name forEachUntil is too
confusing; it makes people (including some members of this expert group)
think that it is supposed to be an encounter-based limiting operation,
rather than an externally-based cancelling operation. Until seems to be
inextricably linked in people's minds to encounter order, with all the
attendant confusion. People seem more able to understand cancellation,
and in particular to understand that cancellation is usually a
cooperative, best-efforts thing rather than the deterministic
content-based limiting that people have in mind.
Accordingly, I think we should rename to "forEachWithCancel", which is
more suggestive (and, secondarily, the ugly name subtly reinforces that
it serves uncommon use cases.)
More information about the lambda-libs-spec-observers