Loose end: ints(), longs()
joe.bowbeer at gmail.com
Tue May 28 10:29:15 PDT 2013
widen and box are different...
asBoxed() is a mouthful. Shouldn't it just be "box()" or "boxed()"?
I prefer the toIntStream() and toLongStream() names anyway, and then
asBoxed() has no leg to stand on.
On Tue, May 28, 2013 at 10:25 AM, Brian Goetz <brian.goetz at oracle.com>wrote:
> 2, Leave "boxed()" as is. There's no reason to rename this, right?
> Well, it seems that "widen to a long" and "box to a Long" are the same
> kind of operation -- give me the same value in a different representation
> -- which suggests a similar naming convention?
More information about the lambda-libs-spec-observers