Loose end: ints(), longs()
brian.goetz at oracle.com
Tue May 28 10:37:42 PDT 2013
BTW, asObjects() could be another name for boxed():
On 5/28/2013 1:31 PM, Brian Goetz wrote:
> To be clear: I wasn't suggesting toIntStream, as much as toInts().
> On 5/28/2013 1:29 PM, Joe Bowbeer wrote:
>> widen and box are different...
>> asBoxed() is a mouthful. Shouldn't it just be "box()" or "boxed()"?
>> I prefer the toIntStream() and toLongStream() names anyway, and then
>> asBoxed() has no leg to stand on.
>> On Tue, May 28, 2013 at 10:25 AM, Brian Goetz <brian.goetz at oracle.com
>> <mailto:brian.goetz at oracle.com>> wrote:
>> 2, Leave "boxed()" as is. There's no reason to rename this,
>> Well, it seems that "widen to a long" and "box to a Long" are the
>> same kind of operation -- give me the same value in a different
>> representation -- which suggests a similar naming convention?
More information about the lambda-libs-spec-observers