Loose ends: Optional

Brian Goetz brian.goetz at oracle.com
Tue May 28 13:28:56 PDT 2013

Sorry, Sam typo'ed and I missed it the first time.  He meant change "ifPresent(Consumer)" to "forEach(Consumer)".  Not isPresent.  

On May 28, 2013, at 4:26 PM, Tim Peierls wrote:

> On Tue, May 28, 2013 at 4:22 PM, Brian Goetz <brian.goetz at oracle.com> wrote:
> > The implementation decides if something can be lazy, I'm ok with these having the same methods. In fact, I suggest we change the name of isPresent to forEach.
> I'm OK with this.  Its a little weird since there is at most one element to each, but the connection to methods on other containers is nice.
> Please, no!
> That would make Optional unusable for all the people who would actually benefit from it. 
> There must be some serious disconnect. I thought this was all settled.
> --tim

More information about the lambda-libs-spec-observers mailing list