RFR (XS): 8081604: rename ScriptingFunctions.tokenizeCommandLine
marcus.lagergren at oracle.com
Tue Jun 2 08:32:08 UTC 2015
> On 02 Jun 2015, at 10:09, Michael Haupt <michael.haupt at oracle.com> wrote:
> Dear all,
> please review and sponsor this small refactoring fix:
> RFE: https://bugs.openjdk.java.net/browse/JDK-8081604
> Changeset: http://cr.openjdk.java.net/~mhaupt/8081604/webrev.00/
> Formerly, ScriptingFunctions.tokenizeCommandLine() was a private utility method. It is now public and used in TestFinder as well, which calls for a more generic name. The change refactors the method name, as well as its local variables.
> Tested with "ant test".
> Dr. Michael Haupt | Principal Member of Technical Staff
> Phone: +49 331 200 7277 | Fax: +49 331 200 7561
> Oracle Java Platform Group | HotSpot Compiler Team
> Oracle Deutschland B.V. & Co. KG, Schiffbauergasse 14 | 14467 Potsdam, Germany
> <http://www.oracle.com/commitment> Oracle is committed to developing practices and products that help protect the environment
More information about the nashorn-dev