5071718: (bf) Add ByteBuffer.slice(int offset, int length)
Roger.Riggs at oracle.com
Tue Feb 26 16:46:46 UTC 2019
The summary line should stand on it own.
It should explicitly mention ByteBuffer or XXXBuffer by name and name
the new method. For example.
"Add a slice method to ByteBuffer and Buffer to create a subsequence
given an absolute position and size."
I would use present tense instead of future tense.
The future tense could be read as being indefinite about when that is true.
"will be" -> "are"
But it is consistent with existing methods.
Buffer.java: 141: it looks odd to have capital "It" after ":"
On 02/26/2019 10:55 AM, Brian Burkhalter wrote:
>> On Feb 26, 2019, at 12:43 AM, Alan Bateman <Alan.Bateman at oracle.com
>> <mailto:Alan.Bateman at oracle.com>> wrote:
>> On 26/02/2019 01:48, Brian Burkhalter wrote:
>>> Hi Brent,
>>> That does read better.
>> It's consistent with the existing slice method so I think it's good too.
> Webrev  and CSR  updated accordingly.
>> Otherwise looks good to me, kudos to Roger for spotting the error
>> with the 0 length case, that would have been embarrassing to get wrong.
> Indeed: good catch, Roger!
>  http://cr.openjdk.java.net/~bpb/5071718/webrev.02/
>  https://bugs.openjdk.java.net/browse/JDK-8219608
More information about the nio-dev