API Review RT:17407 Canvas Node

Richard Bair richard.bair at oracle.com
Fri Apr 20 19:20:59 PDT 2012

>>>> drawFoo() vs. strokeFoo() for drawing the outline of something?
>>> I don't have any clear preference for this but people are probably more used to drawFoo().
>> While drawFoo() will be more familiar to Swing developers, strokeFoo() is more descriptive (after all, doesn't fillFoo() also draw something?), and more consistent with a Shape node's fill / stroke attributes. Also, HTML5 uses strokeFoo().
> I agree. From a logical point of view and also because HTML5 uses it strokeFoo() is probably the better name.

Ya, I would have gone with "strokeFoo" just to match the terminology in the rest of FX. That HTML 5 uses it too is just bonus. +1 from me on that.

More information about the openjfx-dev mailing list