WebStart Install Fail

Scott Palmer swpalmer at gmail.com
Wed Dec 12 11:26:51 PST 2012

Would you like it filed in the JavaFX Jira or the Java Bug Reporter?  I wasn't sure if this was specific to the JavaFX deployment toolchain or not.


On 2012-12-12, at 2:20 PM, Joe McGlynn <joe.mcglynn at oracle.com> wrote:

> Hi Scott,
> The publisher (signer) was changed to Sun for this release intentionally due to problems in the past with the JRE autoupdate on Win 32, so that's expected.
> Can you file a bug on this please with the details on your platform (OS, pre-existing JRE, etc?)
> I just tried this and it works as expected on my system that already has 7u10 installed.
> On Dec 12, 2012, at 11:07 AM, Scott Palmer <swpalmer at gmail.com> wrote:
>> Recall the previous discussions about deployment...
>> I just tried to start the JFXExtras 2  Ensemble application.
>> I clicked the image to run it via web start.
>> It downloaded and I saw a progress bar in a window titled "JavaFX
>> Application Preview" and then the JRE 1.7.0_10 installer failed.
>> "Unable to launch the application."
>> Name: J2RE 1.7.0_10 Installer
>> Publisher: Sun Microsystems, Inc.
>> From: http://javadl.sun.com
>> (Not from Oracle?)
>> Details:
>> java.lang.UnsatisfiedLinkError:
>> C:\Users\scott.palmer\AppData\LocalLow\Sun\Java\Deployment\cache\6.0\ext\E1355338521796\j2re-installer.dll:
>> Can't load IA 32-bit .dll on a AMD 64-bit platform
>>    at java.lang.ClassLoader$NativeLibrary.load(Native Method)
>>    at java.lang.ClassLoader.loadLibrary1(Unknown Source)
>>    at java.lang.ClassLoader.loadLibrary0(Unknown Source)
>>    at java.lang.ClassLoader.loadLibrary(Unknown Source)
>>    at java.lang.Runtime.load0(Unknown Source)
>>    at java.lang.System.load(Unknown Source)
>>    at com.sun.webstart.installers.Main.install(Main.java:156)
>>    at com.sun.webstart.installers.Main.main(Main.java:554)
>>    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>>    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
>>    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
>>    at java.lang.reflect.Method.invoke(Unknown Source)
>>    at com.sun.javaws.Launcher.executeApplication(Unknown Source)
>>    at com.sun.javaws.Launcher.executeMainClass(Unknown Source)
>>    at com.sun.javaws.Launcher.doLaunchApp(Unknown Source)
>>    at com.sun.javaws.Launcher.run(Unknown Source)
>>    at java.lang.Thread.run(Unknown Source)
>> In other words... a pathetic user experience.
>> I would have thought that the people behind the JFXExtras project are
>> pretty competent developers.  If they can't get the JFXExtras project
>> deployment to work...
>> Scott

More information about the openjfx-dev mailing list