Affine transforms - matrix algebra

Pavel Safrata pavel.safrata at
Thu Jul 12 04:46:51 PDT 2012

On 12.7.2012 11:50, Martin Desruisseaux wrote:
> Le 12/07/12 11:28, Pavel Safrata a écrit :
>>>>> * Rename 'getConcatenation' as .. well .. 'getPrependage' :-)
>>>> I missed that method... What would its function? Or are we are 
>>>> talking about something like a 'getTransformCoefficients()' method?
>>> This method is similar to concatenate (prepend) except that it is 
>>> defined on parent Transform class and returns the result in a new 
>>> Transform instance (allows for multiplicating arbitrary - possibly 
>>> immutable - transfroms).
>> What about something like getCompound(Transform)? Probably switching 
>> its meaning so that a.getCompound(b) returns equivalent transform to 
>> a.append(b).
> I'm not sure if this is relevant to JavaFX Affine, but in the 
> vocabulary used by the ISO 19111 international standard (Geographic 
> information — Spatial referencing by coordinates), "compound" and 
> "concatenated" are slightly different concepts. We have "compound" 
> coordinate systems, but "concatenated" transforms. If consistency with 
> ISO 19111 was considered a worthy bonus, then "concatenate" or 
> "getConcatenation" would be quite appropriate vocabulary.
> Not exactly ISO 19111 but closely related, the Open Geospatial 
> Consortium defined this method:
> Martin

Ok, thanks. We need to be consistent at least in scope our transforms, 
so let's pick from

1) createConcatenatedTransform, createInvertedTransform
2) getConcatenatedTransform, getInvertedTransform
3) createConcatenatenation, createInverse
4) getConcatenation, getInverse

I'd probably vote for #3. Any other votes/suggestions?


More information about the openjfx-dev mailing list