API REVIEW: WebView.scale property (for JavaFX 3.0 now)

Kevin Rushforth kevin.rushforth at oracle.com
Mon Jul 23 11:25:49 PDT 2012

Kirill already answered the question of its being a node property:  Node 
already has xScale and yScale properties...this is something subtly 

I think either zoom or zoomFactor would be fine (I would note that zoom 
is shorter, so might be better if it won't be confusing).

-- Kevin

John C. Turnbull wrote:
> Just "zoomProperty" sounds right but, as I said, I think it should be at
> Node level so that other node types can use it too, especially ImageView and
> graphics nodes.  It should zoom the contents only (not the scroll bars
> though the latter should update accordingly to reflect the changes in the
> dimensions of the content and the new relative position).
> -jct
> -----Original Message-----
> From: openjfx-dev-bounces at openjdk.java.net
> [mailto:openjfx-dev-bounces at openjdk.java.net] On Behalf Of Peter
> Zhelezniakov
> Sent: Monday, 23 July 2012 19:21
> To: Leonid Popov
> Cc: openjfx-dev at openjdk.java.net; Sergey Malenkov
> Subject: Re: API REVIEW: WebView.scale property (for JavaFX 3.0 now)
> On 07/20/12 20:14, Leonid Popov wrote:
>> It sounds reasonable, assuming that scaleX/scaleY have slightly 
>> different semantics (they apply to the whole view, including 
>> scrollbars, while the proposed property should affect WebView contents 
>> only). Any other opinions on scale vs. zoom?
> I named it scaleProperty for consistency as we already had
> fontScaleProperty. OTOH I agree 'zoom' may sound more familiar and intuitive
> than 'scale'. I don't have strong preference now.
> Should we name it just zoomProperty, or maybe zoomFactorProperty? Native
> speakers please advise!
> Thanks!
> --
> Peter

More information about the openjfx-dev mailing list