Fwd: hello and macosx build trouble

René Jansen rvjansen at xs4all.nl
Sat Aug 10 08:47:05 PDT 2013

ah, this list does not have a reply-to this list. Sorry about that, Richard, I noticed that only now.

In the meantime, I found out that the missing JSObject has been added three times to my system by the git clone, but it is not compiled and on the classpath at the right moment. Any clues on what the best way is to make sure this dependency is fulfilled? Is it my commenting out of the plugin that causes this?

best regards,

René Jansen.

Begin forwarded message:

> From: René Jansen <rvjansen at xs4all.nl>
> Subject: Re: hello and macosx build trouble
> Date: 10 augustus 2013 16:53:59 CEST
> To: Richard Bair <richard.bair at oracle.com>
> Hi Richard,
> On 10 aug. 2013, at 15:51, Richard Bair <richard.bair at oracle.com> wrote:
>> Hi Rene,
>> I just did a fresh clone and build and it succeeded for me, so now we have to figure out what the difference is.
>>> I started with building OpenJDK 8
>> This might be the first issue, I've always built against the dev preview builds of JDK 8, not OpenJDK 8. I tried to sort this out with Mario Torre a month back but didn't get to the bottom of it.
> I might have to try that.
>>> Now I am trying to build OpenJFX. I have gone past the hurdle of the Gradle buiildfile requiring a JDK build number larger than 100 - I set this to 0 and it happily trucks on
>> I assume you were using the very latest OpenJDK 8 though?
> Yes.
>>> FAILURE: Build failed with an exception.
>>> * What went wrong:
>>> Could not resolve all dependencies for configuration ':graphics:compile'.
>>>> Could not find :plugin:.
>>> Required by:
>>>   rt:graphics:unspecified
>> This is most likely bailing when looking for plugin.jar (which isn't part of OpenJDK). I believe this is just because the code is looking for JSObject. If you edit build.gradle and take out the plugin dependency, you can see where the build fails and why without it.
>> Richard
> Thank you. This worked, and it got further, but it is missing the netscape javascript package now, as illustrated by the below:
> :checkJfxrtJar
> :updateCacheIfNeeded UP-TO-DATE
> :verifyJava
> :base:processVersionInfo UP-TO-DATE
> :base:compileJava UP-TO-DATE
> :base:processResources UP-TO-DATE
> :base:classes UP-TO-DATE
> :base:jar UP-TO-DATE
> :graphics:compileJava
> Download http://download.eclipse.org/eclipse/updates/3.7/R-3.7.2-201202080800/plugins/org.eclipse.swt.cocoa.macosx.x86_64_3.7.2.v3740f.jar
> [ant:javac] /Users/rvjansen/apps/rt/modules/graphics/src/main/java/com/sun/javafx/application/HostServicesDelegate.java:34: error: package netscape.javascript does not exist
> [ant:javac] import netscape.javascript.JSObject;
> [ant:javac]                           ^
> [ant:javac] /Users/rvjansen/apps/rt/modules/graphics/src/main/java/com/sun/javafx/application/HostServicesDelegate.java:88: error: cannot find symbol
> [ant:javac]     public abstract JSObject getWebContext();
> [ant:javac]                     ^
> [ant:javac]   symbol:   class JSObject
> [ant:javac]   location: class HostServicesDelegate
> [ant:javac] /Users/rvjansen/apps/rt/modules/graphics/src/main/java/javafx/application/HostServices.java:30: error: package netscape.javascript does not exist
> [ant:javac] import netscape.javascript.JSObject;
> etc.
> This might have to do with Nashorn replacing Rhino?
> best regards,
> René.

More information about the openjfx-dev mailing list