Javafxpackager build error on Win7 64

Kevin Rushforth kevin.rushforth at
Fri Dec 13 16:42:51 PST 2013

I saw something similar to this when I had a newer version of Microsoft 
.net installed, but I can't remember if it was exactly the same error.

-- Kevin

Francisco Javier Godino wrote:
> Hello:
> I ran the build process "gradle sdk" and I'm receiving the following error:
> LNK1112 module machine type X86 conflicts with target machine type x64
> Part of the log:
> Compiling native files: []
> Starting process 'command 'C:/Program Files (x86)/Microsoft SDKs/Windows/v7.0A/Bin/RC.Exe''. Working directory: C:\Desarrollos\javafxopen\rt\modules\fxpackager Command: C:/Program Files (x86)/Microsoft SDKs/Windows/v7.0A/Bin/RC.Exe /nologo /l 0x409 /r /dJFX_DVERSION=8 /dJFX_VERSION=8 /foC:\Desarrollos\javafxopen\rt\modules\fxpackager\build/native/javafxpackager/javafxpackager.res src/main/native/javafxpackager/win/javafxpackager.rc
> Successfully started process 'command 'C:/Program Files (x86)/Microsoft SDKs/Windows/v7.0A/Bin/RC.Exe''
> Process 'command 'C:/Program Files (x86)/Microsoft SDKs/Windows/v7.0A/Bin/RC.Exe'' finished with exit value 0 (state: SUCCEEDED)
> Starting process 'command 'C:/Program Files (x86)/Microsoft Visual Studio 10.0/VC/BIN/amd64/link.exe''. Working directory: C:\Desarrollos\javafxopen\rt\modules\fxpackager Command: C:/Program Files (x86)/Microsoft Visual Studio 10.0/VC/BIN/amd64/link.exe /machine:X86 /nologo /opt:REF /incremental:no /manifest kernel32.lib advapi32.lib /out:C:\Desarrollos\javafxopen\rt\modules\fxpackager\build/native/javafxpackager/javafxpackager.exe C:\Desarrollos\javafxopen\rt\modules\fxpackager\build/native/javafxpackager/javafxpackager.obj C:\Desarrollos\javafxopen\rt\modules\fxpackager\build/native/javafxpackager/javafxpackager.res
> Successfully started process 'command 'C:/Program Files (x86)/Microsoft Visual Studio 10.0/VC/BIN/amd64/link.exe''
> C:\Desarrollos\javafxopen\rt\modules\fxpackager\build/native/javafxpackager/javafxpackager.obj : fatal error LNK1112: module machine type 'x64' conflicts with target machine type 'X86'
> Process 'command 'C:/Program Files (x86)/Microsoft Visual Studio 10.0/VC/BIN/amd64/link.exe'' finished with exit value 1112 (state: FAILED)
> :fxpackager:buildJavaFXPackager FAILED
> The line in build.gradle is:
> doLast {
>                 mkdir "$buildDir/javafxpackager"
>                 exec({
>                     commandLine("$WIN.fxpackager.linker", "/nologo", "/opt:REF", "/incremental:no", "/manifest", "kernel32.lib", "advapi32.lib",
>                             "/out:$buildDir/native/javafxpackager/javafxpackager.exe",
>                             "$buildDir/native/javafxpackager/javafxpackager.obj",
>                             "$buildDir/native/javafxpackager/javafxpackager.res")
>                     environment(WINDOWS_NATIVE_COMPILE_ENVIRONMENT)
>                 })
>             }
> Do I need to change something?
> Thanks in advance!!
> Javier

More information about the openjfx-dev mailing list