[API Review] FX 8 3D API

Richard Bair richard.bair at oracle.com
Wed Feb 6 11:31:20 PST 2013

In this case we should name it something like 'computeAreaInScreen' rather than being a getter.


On Feb 6, 2013, at 11:30 AM, Chien Yang <chien.yang at oracle.com> wrote:

> Hi Richard,
>    Yes, this is my concern too. It is done so mainly to match JavaFX API pattern and our Sample team preferred it (if I remembered correctly). I would prefer to make it a getter method for now if it is fine with you.
> - Chien
> On 2/6/2013 10:40 AM, Richard Bair wrote:
>>> LOD helper property:
>>> >
>>> >/**
>>> >* A read only property that stores the computed area of this
>>> >* {@code Node} projected onto the physical screen in pixel unit.
>>> >*/
>>> >public final double getAreaInScreen()
>>> >public final javafx.beans.property.ReadOnlyDoubleProperty areaInScreenProperty()
>> Can this be efficiently implemented? We ripped out boundsInScene because it was impossible to get it fast enough. Why would this be any different?

More information about the openjfx-dev mailing list