problems with packaging

Jose Martinez jmartine_1026 at
Thu Jan 3 23:51:30 PST 2013

Both problems have been fixed by upgrading to latest JDK and Netbeans.  I guess I should have tried that first.


 From: Jose Martinez <jmartine_1026 at>
To: openjfx mailing list <openjfx-dev at> 
Sent: Friday, January 4, 2013 2:12 AM
Subject: problems with packaging

Tonight I attempted to repackage a new version of an old application and ran into some problems.  First is that ANT can't detect ISCC.exe.  It spits out the following msg:  "Detected [iscc.exe] version 0.0 but version 5.0 is required."

here is the whole msg.....
Detected JavaFX Ant API version 1.2
Launching <fx:jar> task from C:\Program Files (x86)\Java\jdk1.7.0_09\lib\ant-javafx.jar
Launching <fx:deploy> task from C:\Program Files (x86)\Java\jdk1.7.0_09\lib\ant-javafx.jar
Using base JDK at: C:\Program Files (x86)\Java\jdk1.7.0_09\jre
  Skip [MSI Bundler (WiX based)] due to [Can not find WiX tools (light.exe, candle.exe).]
Detected [iscc.exe] version 0.0 but version 5.0 is required.
  Skip [Exe Bundler (based on Inno Setup)] due to [Can not find Inno Setup Compiler (iscc.exe).]

I put the dir "C:\Program Files (x86)\Inno Setup 5" in my Path system variable.  Hopefully I am doing something stupid on my part.

Second problem:
A while ago I did not like that every time I compiled it would build the Inno Setup package, so I disabled it by removing it from the Path.  I would then just compile the .iss file that was created manually when ever I wanted to.... subsequently bypassing the first problem detailed in this email.  The last time I compiled I was using an older version JDK_7u10-32bit.  But I have recently gone down to JDK_7u9-32bit due to problems with u10.  The move to u9 was a few months ago.  But I have not tried to create a package on u9 till tonight.  Anyways when i create the package using Inno Setup and click on the executable it creates I get the following error "This program does not support the version of Windows running on your computer."  The installer never runs.  Has anyone ever ran into this problem?  I was using version 5.5.0 of Inno Setup and experienced the problem with 5.5.2 also.

thank you!

More information about the openjfx-dev mailing list