[API Review]: Node validation
pavel.safrata at oracle.com
Mon Jul 8 04:20:44 PDT 2013
one more discussion topic: perhaps the "validate" name is too general?
Maybe we can come up with more descriptive name? There are all kinds of
nodes and sometimes this name can be misleading (not ringing the layout
bell at all). For example TextField.validate() may look like validating
the input. Also I wouldn't be surprised if users run into problems with
custom nodes having their "validate" methods for different purposes.
On 3.7.2013 14:33, Martin Sladecek wrote:
> JIRA: https://javafx-jira.kenai.com/browse/RT-31133
> I propose a single method "public final void validate()" to be added
> to Node class. The validate method would ensure that the metrics
> (layout bounds) of the Node are valid with regards to the current
> scenegraph (CSS & layout).
> Together with this change, Parent.layout() will be deprecated.
> In my current implementation, validate() method works only if the Node
> is in a Scene. To make it work without a Scene, we'd need to do do
> some small adjustments to CSS (doesn't work with getScene() == null).
> But I'm not sure if such feature would be useful.
More information about the openjfx-dev