[API Review]: Node validation
neugens at redhat.com
Mon Jul 8 06:04:06 PDT 2013
On Mon, 2013-07-08 at 14:20 +0200, Martin Sladecek wrote:
> The plan is to have a final validate() method.
> Anyway, does anybody have a better suggestion? The validate should do
> both CSS and layout and I would like to avoid method name that's too
> descriptive (like validateLayoutAndCSS()) if possible.
> I think the most important thing about the method is that it validates
> the bounds/metrics of the Node, so maybe validateBounds() ?
What about simply doLayout()?
It seems to me that layouting is strictly correlated to CSS, and
doLayout seems a pretty descriptive name for that purpose.
More information about the openjfx-dev