Monocle in 8u25

Benjamin Gudehus hastebrot at
Tue Nov 4 18:23:13 UTC 2014

I ran a simple click test with

"-Dglass.platform=Monocle -Dmonocle.platform=Headless -Dprism.order=sw"

and the GlassRobot on Windows 7 with Java 8u20 and can confirm that the
tests ran headless and clicked on an invisible table row. I also could
browse the Monocle source code within IntelliJ IDEA.

However on Java 8u25 the same test will fail with

Failed to load Glass factory class


C:\Program Files\Java\jdk1.8.0_20\bin>java -version
java version "1.8.0_20-ea"
Java(TM) SE Runtime Environment (build 1.8.0_20-ea-b05)
Java HotSpot(TM) 64-Bit Server VM (build 25.20-b05, mixed mode)


On Tue, Nov 4, 2014 at 6:51 PM, Benjamin Gudehus <hastebrot at>

> I see. Didn't know that. Thanks for the quick response.
> Users from the TestFX project are interested in headless testing (e.g. on
> Windows with Jenkins). There was a blog post [1] a while back, which
> explained how to use TestFX and Java 8 to run headless tests. I've never
> tried this myself, but recently added adapters for GlassRobot and the
> JavaFX event robot to TestFX in order to allow headless testing.
> [1]
> On Tue, Nov 4, 2014 at 6:43 PM, Kevin Rushforth <
> kevin.rushforth at> wrote:
>> Monocle is not included in any 8u release on desktop platforms (Windows,
>> Linux, Mac).
>> -- Kevin
>> Benjamin Gudehus wrote:
>>> Hi!
>>> I noticed `` is missing
>>> from
>>> `jfxrt.jar` at
>>> least in the Windows and Linux builds of Java 8u25, although it is
>>> included
>>> in 8u20.
>>> Is there any specific reason why Monocle is not included? Is there a way
>>> to
>>> use Monocle
>>> in 8u25?
>>> Regards
>>> Benjamin
>>> (Crosspost from:

More information about the openjfx-dev mailing list