JavaFX: Can't load library:

Kevin Rushforth kevin.rushforth at
Tue Apr 21 14:57:12 UTC 2015

When you build OpenJFX it doesn't build the media or webkit libraries by 
default. You can enable them, but they (especially WebKit) require 
additional libraries on your build machine. If you don't build them, it 
will use the ones from the JDK that you use to build. The ones we 
currently ship with 8u60 (and 9) early access don't work on older Linux 


-- Kevin

Александр Свиридов wrote:
> I use centos 6.4 + openjdk8 (build 25.40-b18, mixed mode) and openjfx (I build it from today sources).
> I have 64 box. And I can't use the html components (all other components seem to work normally) - webview,webengine,htmleditor. When I try to use them I get:
> Caused by: java.lang.UnsatisfiedLinkError:Can't load library:/usr/java/j2sdk-image/jre/lib/amd64/
>     at java.lang.ClassLoader.loadLibrary(
>     at java.lang.Runtime.load0(
>     at java.lang.System.load(
>     at
>     at
>     at
>     at com.sun.webkit.WebPage.lambda$static$38(
>     at com.sun.webkit.WebPage$$Lambda$70/
>     at
>     at com.sun.webkit.WebPage.<clinit>(
>     at javafx.scene.web.WebEngine.<init>(
> I tried to find this lib on my PC but didn't find. I tried to find in repos:
> yum provides
> but also didn't find. What should I do?

More information about the openjfx-dev mailing list