Compiling with Visual Studio 2017

carl at carl at
Fri Oct 19 17:46:34 UTC 2018



Thanks for the reply.  I’m following both wiki pages on building the tip and the 8u versions.


For this tag (8.0-b132), I get the following error with Gradle 4, so I downgraded to 1.8.


> java.lang.String cannot be cast to org.gradle.api.artifacts.Configuration


I pulled the version 14.15.26706 from here.  It’s the only subfolder on my system.


C:\Program Files (x86)\Microsoft Visual Studio\2017\Professional\VC\Redist\MSVC




From: Nir Lisker <nlisker at> 
Sent: Friday, October 19, 2018 1:31 PM
To: carl at
Cc: openjfx-dev at Mailing <openjfx-dev at>
Subject: Re: Compiling with Visual Studio 2017


Hi Carl,


The instructions for building OpenJFX 8 are in the wiki [1], though I never built this version myself.


Usually when "cl.exe" is not found it's because of a wrong MSVC_VER variable value. In VS 2017, this file is located under "VC\Tools\MSVC\<MSVC_VER>\bin" (there are 4 versions under this folder tree). It could be that the MSVC_VER value does not match the folder name in this path. I don't know why you're looking for it inside cygwin64, but, again, I am unfamiliar with this build.


Also, the Gradle version needs to be 4.8, not 1.8.


Good luck,





On Fri, Oct 19, 2018 at 8:05 PM <carl at <mailto:carl at> > wrote:


I'm trying to build 8.0-b132 for Windows with Visual Studio 2017.  I was
able to build the Java code successfully, but am getting a path error

13:00:54.444 [ERROR] [org.gradle.BuildExceptionReporter] Caused by: Cannot run program "C:/cygwin64/VC/BIN/amd64/cl.exe"
(in directory "D:\hg\rt\modules\fxpackager"): CreateProcess error=2, The
system cannot find the file specified

This is my environment

export JAVA_HOME=D:/Java/open-jdk8u172-b11

export GRADLE_HOME=C:/gradle/gradle-1.8


export VS150COMNTOOLS="C:\\Program Files (x86)\\Microsoft <file://Microsoft>  Visual

export MSVC_VER=14.15.26706

export WINSDK_DIR="C:/Program Files (x86)/Microsoft SDKs/Windows/v10.0A"

I tried replacing the win.gradle from the 8.0-b132 with the file from the
tip.  In that case, I got a "WINSDK_DIR" not defined error.

Does anyone build openjfx 8 with 2017 or is everyone using the older VS for
the backports?  DirectX gave me an error when I tried to install the 2010
SDK.  Are the DirectX APIs embedded in VS now?



More information about the openjfx-dev mailing list