Stuck attempting to run/develop a manual unit test

Ajit Ghaisas ajit.ghaisas at
Fri Apr 3 10:52:01 UTC 2020

Hi Craig,

    Here is how I run the ButtonMnemonicPositionTest.

    $ export FX_LIB=/Users/AG/aaa/jfx/build/sdk/lib
    $ cd /Users/AG/aaa/jfx/tests/manual/UI
    $ javac --module-path $FX_LIB --add-modules javafx.controls
    $ java --module-path $FX_LIB --add-modules javafx.controls ButtonMnemonicPositionTest

    Hope this helps.

    We can discuss further on your PR.


> On 03-Apr-2020, at 3:56 PM, Craig Cavanaugh <craig.cavanaugh at> wrote:
> I am trying to create a manual unit test for RFR: 8129123 and I'm using the
> existing as a template to make sure
> everything is working correctly.
> I'm using an Ubuntu 18.04.4 build environment using the default 11.0.6
> openjdk.
> openjfx is successfully compiling and passing tests following the wiki
> instructions
> I'm able to compile ButtonMnemonicPositionTest successfully as shown below.
> javac -classpath  .:/home/craig/IdeaProjects/jfx/build/sdk/lib/*
> But attempts to run are failing despite a successful compile:
> java -classpath  .:/home/craig/IdeaProjects/jfx/build/sdk/lib/*
> ButtonMnemonicPositionTest
> Error: JavaFX runtime components are missing, and are required to run this
> application
> I've also tried running using the modular-sdk after a Gradle build and no
> luck either after finding a recommendation on the list that the module
> approach should be used for testing.
> java --module-path /home/craig/IdeaProjects/jfx/build/modular-sdk/modules
> --add-modules=javafx.controls ButtonMnemonicPositionTest
> Error occurred during initialization of boot layer
> java.lang.module.FindException: Module javafx.controls not found
> I've been search through the list archive and haven't found a solution.
> I'm sure I'm doing something wrong.
> Some help please!
> Regards,
> Craig

More information about the openjfx-dev mailing list