Unable to import OpenJFX Build into Eclipse

Andrew Waters gb91757 at gmail.com
Sat Aug 15 10:55:09 UTC 2020

Hi All,

I'm trying to diagnose a bug in OpenJFX that I've been struggling with 
on and off for almost a year(!) and I decided to build OpenJFX from 
source and use Eclipse to help.  I've built a brand new Ubuntu 
20.04.1-Desktop system with OpenJDK 14.0.1 and the latest stable OpenJFX 
14.  I've run the Gradle build and run the tests and all looks 100%.

When importing the root directory (home/jdkdev/dev/jfx) into Eclipse 
using the gradle import tool (using the wrapper option as recommended) I 
get this build path error:

Cannot nest 
inside library 

It seems to be trying to set up a looped import to itself somehow.  I've 
tried to edit the build path in eclipse but the fields appear to be all 
non-editable.  Has anyone any idea as to what the problem is and how to 
fix it?  Has anyone recently done a successful import with these latest 

As this is the base module none of the other modules compile of course 
so they too may have other problems once the base module is fixed.

I tried the "existing projects" import too but that just appears to have 
even more problems.


Andrew Waters


More information about the openjfx-dev mailing list