"Using an IDE" Page outdated

Robert Lichtenberger r.lichtenberger at gmail.com
Tue Jan 14 10:08:28 UTC 2020

> Did you end up reverting the .classpath and .project files?
I started over, not importing as gradle but  as java projects.

I also just found
and with Tom's hint:

> i run them with
> -Djava.library.path=/Users/tomschindl/OpenJFX/openjdk-jfx/build/sdk/lib
> -Djavafx.toolkit=test.com.sun.javafx.pgstub.StubToolkit
I was finally able to run a test.

Maybe Nir could add a note about those two properties in the section
""JUnit tests"?

To sum up my findings/problems:
* gradlew is not executable; This should easily be changeable and would
make live easier for linux developers
* Building with gradle didn't work out of the box due to deprecations in
* The netbeans/intellij parts of the Wiki page seem to be the most outdated
whereas Nir is maintaining the eclipse part quite well. Maybe we should put
eclipse to the top and/or recommend using eclipse then. Or at least warn
the reader in the sections about netbeans and intellij beeing outdated. I
am a longtime eclipse user but after reading the wiki page tried netbeans
first (and failed miserably...)
* Using gradle/buildship in eclipse is not the "preferred" way. Maybe we
should remove this way altogether so as to not mislead people. I admit not
having read the wiki thouroughly enough though :-).
* hlsl problem under linux
* To run unit tests two VM arguments must be set. These should be mentioned
in the wiki.

Thanks to everyone for helping me ;-).

Am Di., 14. Jan. 2020 um 09:50 Uhr schrieb Tom Schindl <
tom.schindl at bestsolution.at>:

> I think the issue there is
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=507629 as Nir commented
> there as well I'm fairly sure this is the one you see ;-)
> Tom
> On 14.01.20 09:47, Tom Schindl wrote:
> > On 14.01.20 09:36, Robert Lichtenberger wrote:
> >> I've just simply removed the two missing source folders and only one
> >> error remains:
> >> * The blank final field dialog may not have been initialized Dialog.java
> >> /controls/src/main/java/javafx/scene/control line 521
> >> which seems to me like an error within the eclipse compiler.
> >>
> >> Ignoring this error, I've tried to execute
> >
> > yes it is and it is already logged in Bugzilla there - you can just
> > remove final in your local workspace ;-)
> >
> > Tom
> >
> --
> Tom Schindl, CTO
> BestSolution.at EDV Systemhaus GmbH
> Salurnerstrasse 15. A-6020 Innsbruck
> Reg. Nr. FN 222302s am Firmenbuchgericht Innsbruck

More information about the openjfx-dev mailing list