RFR: 8272870: Add convenience factory methods for border and background [v2]

Nir Lisker nlisker at openjdk.java.net
Thu Sep 9 23:27:03 UTC 2021

On Tue, 7 Sep 2021 06:31:18 GMT, Ambarish Rapte <arapte at openjdk.org> wrote:

>> Since the `Background` constructors take a list of `Paint` objects, I think saying a "single" `{@code Paint}` is helpful. I can see how adding "for `BackgroundFill`" (or maybe "as a `BackgroundFill`"?) might make it clearer.
> Sound good to me, It would read like `A convenience factory method for creating a Background by specifying a single {@code Paint} as a BackgroundFill`

Does mentioning `BackgroundFill` in the description contribute something? The `@implSpec` tag gives that info. In my eyes, if the docs say the background will use a single `Paint` then I know exactly what I'm going to get regardless of what it uses in the implementation.


PR: https://git.openjdk.java.net/jfx/pull/610

More information about the openjfx-dev mailing list