[9] RFR 8165275: Replace the reflective call to the implUpdate method in HandshakeMessage::digestKey

Valerie Peng valerie.peng at oracle.com
Mon Oct 10 19:49:46 UTC 2016


Thanks for the review. I have updated the MessageDigestSpi2 class 
accordingly:
http://cr.openjdk.java.net/~valeriep/8165275/webrev.01/src/java.base/share/classes/sun/security/util/MessageDigestSpi2.java.html

Valerie

On 10/10/2016 3:15 AM, Xuelei Fan wrote:
> As this API is only used for legacy SSL 3.0, alternatively we may 
> deprecate and remove the support of MessageDigestSpi2 in the future.  
> I may add a note to MessageDigestSpi2, like:
>
>    This is for SSL 3.0 implementation only, please don't
>    use it for other purpose.
>
> Otherwise, looks fine to me.
>
> Thanks,
> Xuelei
>
> On 10/5/2016 6:07 AM, Valerie Peng wrote:
>> Hi Xuelei,
>>
>> Could you please help reviewing this JSSE-related code refactoring?
>>
>> Bug: https://bugs.openjdk.java.net/browse/JDK-8165275
>> Webrev: http://cr.openjdk.java.net/~valeriep/8165275/webrev.00/
>>
>> Thanks,
>> Valerie



More information about the security-dev mailing list