RFR: 383: More fuzzy matching of bug ids in PR titles

Robin Westberg rwestberg at openjdk.java.net
Thu May 14 14:34:41 UTC 2020

On Thu, 14 May 2020 13:56:00 GMT, Jorn Vernee <jvernee at openjdk.org> wrote:

>> Hi all,
>> Please review this change that allows a more relaxed matching of bug ids in PR titles. Also contains a bit of
>> refactoring to make it explicit when the project name could be part of the bug id. There were several places that
>> expected the project name to not be present (as they would fetch the issue using the key from a specific project) -
>> these now explicitly use the shortId.  Best regards, Robin
> vcs/src/main/java/org/openjdk/skara/vcs/openjdk/Issue.java line 89:
>> 88:     public String toShortString() {
>> 89:         return id + ": " + description;
>> 90:     }
> Bit confusing here when also looking at the toString method impl. Maybe you should rename the `id` field to `shortId`
> now? (to match the method names)

Makes sense, will change it.. There's probably a better name than `shortId` waiting to be discovered out there, but I
didn't find it..


PR: https://git.openjdk.java.net/skara/pull/623

More information about the skara-dev mailing list