Merged with jdk8/tl and Ubuntu 12.10 build issues

Werner Dietl wdietl at
Wed Nov 7 23:04:31 PST 2012

FYI, I merged with all repositories in jdk8/tl and pushed to

On my Ubuntu 12.10 system with gcc (Ubuntu/Linaro 4.7.2-2ubuntu1) 4.7.2 I
currently cannot build the hotspot and jdk repositories.

File build-jdk-error-hotspot.txt.gz contains the whole build configuration
and error message.
The attached diff (2012-11-07-hotspot.diff) resolves the problems in
hotspot by a few simple additions.

However, the jdk project still doesn't build anymore; see
build-jdk-error-jdk.txt.gz for the link error I have there.

I tried with both the old build system and the new build system, with the
same results.

Note that these errors seem to be connected with my recent upgrade from
Ubuntu 12.04 to 12.10. On Ubuntu 12.04 I could successfully build

Also note that I can successfully build all repositories on our build
server, a Fedora 15 system with gcc 4.6.3:

Does anyone successfully compile OpenJDK with gcc 4.7.2 and/or Ubuntu 12.10?

I tried providing "CC" and "CXX" environment variables to the new configure
script to switch to a gcc-4.6 installation. However, the build system
insisted on using the default gcc-4.7 installation.
Does anyone know how to use a different gcc installation?

There is currently an ambiguity between annotated type casts and a form of
lambda expressions. I will investigate these additional failures.
I only merged the repositories so far. I did not integrate type annotations
with lambda yet.

All help with these build issues would be greatly appreciated!

cu, WMD.

-------------- next part --------------
An HTML attachment was scrubbed...
-------------- next part --------------
A non-text attachment was scrubbed...
Name: build-jdk-error-hotspot.txt.gz
Type: application/x-gzip
Size: 5410 bytes
Desc: not available
Url : 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 2012-11-07-hotspot.diff
Type: application/octet-stream
Size: 1679 bytes
Desc: not available
Url : 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: build-jdk-error-jdk.txt.gz
Type: application/x-gzip
Size: 602 bytes
Desc: not available
Url : 

More information about the type-annotations-dev mailing list