Equality for values -- new analysis, same conclusion
brian.goetz at oracle.com
Wed Aug 21 01:16:03 UTC 2019
> (although I'm not looking forward to an alternate name or a default
> value for LocalDate).
Assuming that this is what we will have to do, it would be a useful exploration to identify sensible idioms and guidelines for how to name these classes. Are these new ad-hoc names (Opt for the new Optional), or a mechanically derived scheme such as Optional.Inline? Finding a less objectionable scheme here can go a long way to mitigating the sadness of having to give these things new names.
More information about the valhalla-dev